summaryrefslogtreecommitdiff
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-08 09:08:38 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-08 09:08:38 +0000
commite8d897309949d4c2cc7a77ba0e6ca84f071fa6e9 (patch)
tree66a9a28ea0c69b059939becc0f335bc8ec1d5437 /openwrt/package/Makefile
parent75821f0878d074fff9467e4c74d2ed718a35002f (diff)
add some fixes for parallel build (does not work with -j4 yet, but it gets most packages compiled now)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@577 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 99696770c1..2db33703b2 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -1,6 +1,7 @@
# Main makefile for the packages
include $(TOPDIR)/rules.mk
+package-:=tcp_wrappers
package-y:=openwrt
package-$(BR2_PACKAGE_AICCU) += aiccu
package-$(BR2_PACKAGE_ARPTABLES) += arptables
@@ -52,6 +53,7 @@ package-$(BR2_PACKAGE_ZLIB) += zlib
package-$(BR2_PACKAGE_DHCPFWD) += dhcp-forwarder
package-$(BR2_PACKAGE_LIBNET) += libnet
package-$(BR2_PACKAGE_LIBMYSQLCLIENT) += mysql
+package-$(BR2_PACKAGE_LIBPCAP) += libpcap
package-$(BR2_PACKAGE_LIBPQ) += postgresql
all: compile install
@@ -77,7 +79,7 @@ libnet-compile: libpcap-compile
mysql-compile: ncurses-compile zlib-compile
postgresql-compile: zlib-compile
-$(patsubst %,%-prepare,$(package-y) $(package-m)): linux-install
+$(patsubst %,%-prepare,$(package-y) $(package-m) $(package-)): linux-install
%-prepare:
@[ -f $(STAMP_DIR)/.$@ ] || $(MAKE) -C $(patsubst %-prepare,%,$@) prepare