summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-18 11:18:37 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-18 11:18:37 +0000
commitf82e916164a6829e5126168e73dadaa6998a8a3e (patch)
treea9172b8c080f2205a21a7857cfc091806f63d392 /include
parentd2f3ca4c6e48070cc7c14b3a4821793220e36b3c (diff)
build: add required exports for dependency tracking
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37387 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/package-ipkg.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 73fed05b17..696de156cf 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -54,7 +54,10 @@ ifneq ($(PKG_NAME),toolchain)
@( \
rm -f $(PKG_INFO_DIR)/$(1).missing; \
( \
- export READELF=$(TARGET_CROSS)readelf XARGS="$(XARGS)"; \
+ export \
+ READELF=$(TARGET_CROSS)readelf \
+ OBJCOPY=$(TARGET_CROSS)objcopy \
+ XARGS="$(XARGS)"; \
$(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
) | while read FILE; do \
grep -q "$$$$FILE" $(PKG_INFO_DIR)/$(1).provides || \