summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-01-12 12:27:32 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-01-12 12:27:32 +0000
commitd3d20db23fa342a44e849c61d129c53e28823371 (patch)
treec8a47e3be2f27ae709ec157d055ff899227da11f /include
parentb3da6dea83a94d62f1062e8ea4919a7c4f1c7a24 (diff)
Fix build for individual profiles with dashes in names
Config symbols can have regular dashes, e.g. CONFIG_TARGET_ramips_rt305x_UR-336UN=y So no substitution should be performed on the last part of the symbol. Signed-off-by: Paul Fertser <fercerpav@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39242 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index eca218e0b3..ccec41f71c 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -76,7 +76,7 @@ define Profile
$(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Description)"; \
echo "@@"; \
echo;
- ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
+ ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_))$(1)),y)
PROFILE=$(1)
endif
endef