summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-02 12:12:10 +0000
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-02 12:12:10 +0000
commit1ec77e729290fb4e9c54a4aad74ba9eaac7718d9 (patch)
tree72764bcaecd2601a019eb4f628737c04401198ba /include
parenta6e8ce261968b157919c58307e332440b6f42a98 (diff)
Add package signing infrastructure
Add package signing key and certificate configuration options to the "Image configuration" submenu. If enabled, the Packages.gz list will be signed as file Packages.sig. The passphrase for the signing key can be sourced from a file or entered by the user. The signing certificate is automatically added to the firmware image if opkg-smime is selected. Signed-off-by: Evan Hunt <each@isc.org> Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38284 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 59ea7ef9a7..b7ada69bb4 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -168,6 +168,10 @@ $(eval $(call RequireCommand,svn, \
Please install the subversion client. \
))
+$(eval $(call RequireCommand,openssl, \
+ Please install openssl. \
+))
+
define Require/gnu-find
$(FIND) --version 2>/dev/null
endef