summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-12 21:44:46 +0000
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-12 21:44:46 +0000
commitf9a4428876862007de2b69f3557ac9e983bf94ab (patch)
treeb3f4adf3c4801a2f21c6402851fef99da379cb10 /include
parentaacb286a39cb0632c4ddda7529538c87dc641da5 (diff)
image: if possible use profile name when building .tar.gz images
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38374 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index e0731f0895..f5f1c8fb54 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -141,7 +141,7 @@ endif
ifneq ($(CONFIG_TARGET_ROOTFS_TARGZ),)
define Image/mkfs/targz
# Preserve permissions (-p) when building as non-root user
- $(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
+ $(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE),-$(PROFILE))-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
endef
endif