summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-15 21:37:31 +0000
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-15 21:37:31 +0000
commit62d459dd785da35f20d70f919ca4aca9c2061f9b (patch)
tree64596a9ce786c350e1ad3525940ca59afa4e90df /include
parent985755715545c2e75dbbfc64112312ba75167ae1 (diff)
ubifs: remove breaking commas from ubi calls
The extra commas get output by the shell resulting in errors since the commands that get called with those extra commas are then malformed. Signed-off-by: Joris de Vries <joris@apptrician.nl> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38419 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index c79d823538..8f895a3435 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -125,7 +125,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(STAGING_DIR_HOST)/bin/mkfs.ubifs \
$(if $($(PROFILE)_UBIFS_OPTS), \
$(shell echo $($(PROFILE)_UBIFS_OPTS)), \
- $(shell echo $(UBIFS_OPTS)), \
+ $(shell echo $(UBIFS_OPTS)) \
) \
$(if $(CONFIG_TARGET_UBIFS_FREE_SPACE_FIXUP),--space-fixup) \
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_NONE),--force-compr=none) \
@@ -143,7 +143,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(STAGING_DIR_HOST)/bin/ubinize \
$(if $($(PROFILE)_UBI_OPTS), \
$(shell echo $($(PROFILE)_UBI_OPTS)), \
- $(shell echo $(UBI_OPTS)), \
+ $(shell echo $(UBI_OPTS)) \
) \
-o $(KDIR)/root.ubi \
ubinize.cfg \