diff options
author | jow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2012-01-01 15:11:11 +0000 |
---|---|---|
committer | jow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2012-01-01 15:11:11 +0000 |
commit | e2b9e1a026996e7ee14c4104c49587056ff4027f (patch) | |
tree | 91466786effb4a6d7e4fed0732aabec6e94a0a17 | |
parent | a604775f6617c9a73e239ccd7632c19aa9512750 (diff) |
[toolchain] if CONFIG_BUILD_NLS is selected, compile uClibc with locale support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29633 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Config.in | 2 | ||||
-rw-r--r-- | toolchain/uClibc/Makefile | 1 |
2 files changed, 2 insertions, 1 deletions
@@ -145,7 +145,7 @@ menu "Global build settings" bool "Compile with full language support" help When this option is enabled, packages are built with the full versions of iconv and GNU gettext - instead of the default OpenWrt stubs. + instead of the default OpenWrt stubs. If uClibc is used, it is also built with locale support. config SHADOW_PASSWORDS bool diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile index 5f4ddb5d9f..8c658448b3 100644 --- a/toolchain/uClibc/Makefile +++ b/toolchain/uClibc/Makefile @@ -78,6 +78,7 @@ define Host/Prepare -e 's,^.*UCLIBC_HAS_FPU.*,UCLIBC_HAS_FPU=$(if $(CONFIG_SOFT_FLOAT),n,y),g' \ -e 's,^.*UCLIBC_HAS_SOFT_FLOAT.*,UCLIBC_HAS_SOFT_FLOAT=$(if $(CONFIG_SOFT_FLOAT),y,n),g' \ -e 's,^.*UCLIBC_HAS_SHADOW.*,UCLIBC_HAS_SHADOW=$(if $(CONFIG_SHADOW_PASSWORDS),y,n),g' \ + -e 's,^.*UCLIBC_HAS_LOCALE.*,UCLIBC_HAS_LOCALE=$(if $(CONFIG_BUILD_NLS),y,n),g' \ $(HOST_BUILD_DIR)/.config $(MAKE) -C $(HOST_BUILD_DIR) oldconfig KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS" $(MAKE) -C $(HOST_BUILD_DIR)/extra/config conf KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS" |