diff options
author | nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2007-12-28 15:46:01 +0000 |
---|---|---|
committer | nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2007-12-28 15:46:01 +0000 |
commit | a93683386efd3ac123321caaa2eb7b901c4524d1 (patch) | |
tree | 17b60ca51df0dc0a248c87333ad3cbe6fc5cb85b | |
parent | 923cbdac968d90374968d36fc59a6153f60acd4a (diff) |
add cpio.gz support (patch from #2595)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9986 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Config.in | 7 | ||||
-rw-r--r-- | include/image.mk | 8 |
2 files changed, 15 insertions, 0 deletions
@@ -41,6 +41,13 @@ menu "Target Images" help Build a compressed tar archive of the the root filesystem + config TARGET_ROOTFS_CPIOGZ + bool "cpiogz" + default y if USES_TGZ + depends !TARGET_ROOTFS_INITRAMFS + help + Build a compressed cpio archive of the the root filesystem + config TARGET_ROOTFS_EXT2FS bool "ext2" default y if USES_EXT2 diff --git a/include/image.mk b/include/image.mk index 47f6714d13..d7e4ccd36b 100644 --- a/include/image.mk +++ b/include/image.mk @@ -64,6 +64,12 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y) $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(TARGET_DIR)/ . endef endif + + ifeq ($(CONFIG_TARGET_ROOTFS_CPIOGZ),y) + define Image/mkfs/cpiogz + ( cd $(BUILD_DIR)/root; find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.cpio.gz ) + endef + endif else define Image/BuildKernel cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf @@ -118,6 +124,7 @@ ifneq ($(IB),1) $(call Image/mkfs/jffs2) $(call Image/mkfs/squashfs) $(call Image/mkfs/tgz) + $(call Image/mkfs/cpiogz) $(call Image/mkfs/ext2) $(call Image/mkfs/iso) else @@ -126,6 +133,7 @@ else $(call Image/mkfs/jffs2) $(call Image/mkfs/squashfs) $(call Image/mkfs/tgz) + $(call Image/mkfs/cpiogz) $(call Image/mkfs/ext2) $(call Image/mkfs/iso) endif |