summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-06 14:02:24 +0000
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-06 14:02:24 +0000
commit5263efba39f27c4449157745c84764c517948e63 (patch)
tree970e5ad3a57f1715e316c3a506fe55f6090e3555
parentecb7a97e94e2828b0769819a5a55a4c30ad95138 (diff)
iptables: install libext*.a into staging dir
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36867 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/network/utils/iptables/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 55f3a387bd..03f692ec68 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -375,6 +375,10 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xtables.pc $(1)/usr/lib/pkgconfig/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libip*tc.pc $(1)/usr/lib/pkgconfig/
+
+ # XXX: needed by firewall3
+ $(INSTALL_DIR) $(1)/usr/lib/iptables
+ $(CP) $(PKG_BUILD_DIR)/extensions/libext*.a $(1)/usr/lib/iptables/
endef
define Package/iptables/install