summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-10 15:01:50 +0000
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-10 15:01:50 +0000
commitdd8efd871ebce25289a5954c375e8aa5a6add08c (patch)
treefd589084560f098f0361a662690c5f558d52ee86
parenta6728a1874faa2bbef7f92f345bf5af1f285847f (diff)
Incorrect checkout of git submodules
When checking out git packages, buildroot doesn't seem to track the revisions correctly of any submodules referenced by that project. As a result, the submodule stays at whatever revision was referenced by the head of the master branch. Running a 'git submodule update' after the checkout fixes this problem. Signed-off-by: Owen Kirby <osk@exegin.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38359 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 372db03194..1c3f23e94b 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -88,7 +88,7 @@ define DownloadMethod/git
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
git clone $(URL) $(SUBDIR) --recursive && \
- (cd $(SUBDIR) && git checkout $(VERSION)) && \
+ (cd $(SUBDIR) && git checkout $(VERSION) && git submodule update) && \
echo "Packing checkout..." && \
rm -rf $(SUBDIR)/.git && \
$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \