summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-19 07:46:01 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-19 07:46:01 +0000
commitdb7f4ab4d2a1c5d385bacf2c695b796d81f7c912 (patch)
treefc4b24d257d49bf1fa37f482d183fe7e79ff4457
parentd66efda5367272e0e48dfaec2b00964c42400319 (diff)
sync with buildroot2 from uclibc, add devices, may be used to build other kernel modules for different devices, can be used for other stuff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@267 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--openwrt/target/Config.in3
-rw-r--r--openwrt/target/Makefile.in18
-rw-r--r--openwrt/target/default/openwrt.mk10
-rw-r--r--openwrt/target/default/skel.tar.gzbin0 -> 193 bytes
-rw-r--r--openwrt/target/device/Config.in17
-rw-r--r--openwrt/target/device/Makefile.in2
-rw-r--r--openwrt/target/jffs2/jffs2root.mk5
-rw-r--r--openwrt/target/squashfs-lzma/squashfslzmaroot.mk5
-rw-r--r--openwrt/target/squashfs/squashfsroot.mk5
9 files changed, 53 insertions, 12 deletions
diff --git a/openwrt/target/Config.in b/openwrt/target/Config.in
index 1fad548133..d93df6b1cf 100644
--- a/openwrt/target/Config.in
+++ b/openwrt/target/Config.in
@@ -4,4 +4,5 @@ choice
source "target/squashfs/Config.in"
source "target/squashfs-lzma/Config.in"
endchoice
- comment "After changing root filesystem, do make clean"
+
+source "target/device/Config.in"
diff --git a/openwrt/target/Makefile.in b/openwrt/target/Makefile.in
index c01ade299a..802b576fba 100644
--- a/openwrt/target/Makefile.in
+++ b/openwrt/target/Makefile.in
@@ -1 +1,17 @@
-# Nothing
+# Default target skeleton stuff, may be overridden
+TARGET_SKELETON=target/default/skel.tar.gz
+TARGET_SKEL_DIR=target/default/target_skeleton
+
+include target/device/Makefile.in
+
+openwrt-linux.trx: openwrt-trx
+ PATH=$(TARGET_PATH) trx -o openwrt-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
+
+openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
+ PATH=$(TARGET_PATH) addpattern -2 -i openwrt-linux.trx -o openwrt-gs-code.bin -g
+
+openwrt-g-code.bin: openwrt-gs-code.bin
+ sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin > openwrt-g-code.bin
+
+openwrt-image: openwrt-g-code.bin
+
diff --git a/openwrt/target/default/openwrt.mk b/openwrt/target/default/openwrt.mk
deleted file mode 100644
index 89051cd1bf..0000000000
--- a/openwrt/target/default/openwrt.mk
+++ /dev/null
@@ -1,10 +0,0 @@
-openwrt-linux.trx: openwrt-trx
- PATH=$(TARGET_PATH) trx -o openwrt-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
-
-openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
- PATH=$(TARGET_PATH) addpattern -2 -i openwrt-linux.trx -o openwrt-gs-code.bin -g
-
-openwrt-g-code.bin: openwrt-gs-code.bin
- sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin > openwrt-g-code.bin
-
-openwrt-image: openwrt-g-code.bin
diff --git a/openwrt/target/default/skel.tar.gz b/openwrt/target/default/skel.tar.gz
new file mode 100644
index 0000000000..86cefb1d24
--- /dev/null
+++ b/openwrt/target/default/skel.tar.gz
Binary files differ
diff --git a/openwrt/target/device/Config.in b/openwrt/target/device/Config.in
new file mode 100644
index 0000000000..36d056cadf
--- /dev/null
+++ b/openwrt/target/device/Config.in
@@ -0,0 +1,17 @@
+choice
+ prompt "Device Support"
+ default BR2_TARGET_ALL
+
+config BR2_TARGET_ALL
+ bool "Support for all devices"
+
+config BR2_TARGET_LINKSYS_WRT54G
+ bool "Linksys WRT54G Support"
+
+config BR2_TARGET_LINKSYS_WRT54GS
+ bool "Linksys WRT54GS Support"
+
+config BR2_TARGET_ASUS_WL500G
+ bool "Asus WL-500g Support"
+
+endchoice
diff --git a/openwrt/target/device/Makefile.in b/openwrt/target/device/Makefile.in
new file mode 100644
index 0000000000..92d6e76bc7
--- /dev/null
+++ b/openwrt/target/device/Makefile.in
@@ -0,0 +1,2 @@
+-include target/device/*/*/Makefile.in
+-include target/device/all/Makefile.in
diff --git a/openwrt/target/jffs2/jffs2root.mk b/openwrt/target/jffs2/jffs2root.mk
index 90a60165cb..8dcd00f572 100644
--- a/openwrt/target/jffs2/jffs2root.mk
+++ b/openwrt/target/jffs2/jffs2root.mk
@@ -43,3 +43,8 @@ jffs2root-clean:
jffs2root-dirclean:
rm -rf $(MTD_DIR)
+
+ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
+TARGETS+=jffs2root openwrt-image
+ROOTFS=jffs2
+endif
diff --git a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
index 6f41f93155..722c20524e 100644
--- a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
+++ b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
@@ -48,3 +48,8 @@ squashfslzmaroot-clean:
squashfslzmaroot-dirclean:
rm -rf $(SQUASHFSLZMA_DIR)
+
+ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS_LZMA)),y)
+TARGETS+=squashfslzmaroot openwrt-image
+ROOTFS=squashfslzma
+endif
diff --git a/openwrt/target/squashfs/squashfsroot.mk b/openwrt/target/squashfs/squashfsroot.mk
index 4dd6800a0d..d3a104a83f 100644
--- a/openwrt/target/squashfs/squashfsroot.mk
+++ b/openwrt/target/squashfs/squashfsroot.mk
@@ -47,3 +47,8 @@ squashfsroot-clean:
squashfsroot-dirclean:
rm -rf $(SQUASHFS_DIR)
+
+ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS)),y)
+TARGETS+=squashfsroot openwrt-image
+ROOTFS=squashfs
+endif