diff options
author | lars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2009-01-29 23:52:35 +0000 |
---|---|---|
committer | lars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2009-01-29 23:52:35 +0000 |
commit | 2edc1eaf4b6b2e58f9e0c7d95a7d79d35910c8b2 (patch) | |
tree | ad37947d89ad9b7e8a26deb2c22bdc5ccd606f82 | |
parent | fbdf4d4e510e1bfb4a75d0772e2fcca0301aa238 (diff) |
Add menuconfig option for enabling profiling in the kernel.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14272 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Config.in | 6 | ||||
-rw-r--r-- | include/kernel-defaults.mk | 1 |
2 files changed, 7 insertions, 0 deletions
@@ -124,6 +124,12 @@ config KERNEL_KALLSYMS default n help This will give you more information in stack traces from kernel oopses +config KERNEL_PROFILING + bool "Compile the kernel with profiling enabled" + default n + help + Enable the extended profiling support mechanisms used by profilers such + as OProfile. endmenu diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk index 4aa5c0ef18..e3897a64cc 100644 --- a/include/kernel-defaults.mk +++ b/include/kernel-defaults.mk @@ -87,6 +87,7 @@ endef define Kernel/Configure/Default $(LINUX_CONFCMD) > $(LINUX_DIR)/.config.target echo "$(if $(CONFIG_KERNEL_KALLSYMS),CONFIG_KALLSYMS=y,# CONFIG_KALLSYMS is not set)" >> $(LINUX_DIR)/.config.target + echo "$(if $(CONFIG_KERNEL_PROFILING),CONFIG_PROFILING=y,# CONFIG_PROFILING is not set)" >> $(LINUX_DIR)/.config.target echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target $(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config > $(LINUX_DIR)/.config.override |