diff options
author | florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2013-04-05 12:35:56 +0000 |
---|---|---|
committer | florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2013-04-05 12:35:56 +0000 |
commit | 65eb3b951b9cad83e142f30b3aead9fca973cdb8 (patch) | |
tree | cc5c433e7aec09e82e361f9ee955bad18514aa33 | |
parent | 28dd9883f0907e282820a95694f9dd59879cd32c (diff) |
rules.mk: MIPS16 builds get a different toolchain
To be safe, build "m16" into the toolchain and target architecture the
same way mips32r2 does:
target-mips_r2_m16_uClibc-0.9.33.2
toolchain-mips_r2_m16_gcc-4.6-linaro_uClibc-0.9.33.2
Signed-off-by: Jay Carlson <nop@nop.com>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36198 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | rules.mk | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -65,6 +65,7 @@ ifneq ($(filter -mips%r2,$(TARGET_OPTIMIZATION)),) endif ifneq ($(findstring -mips16,$(TARGET_OPTIMIZATION)),) TARGET_ASFLAGS_OVERRIDE:=-mno-mips16 + ARCH_SUFFIX:= $(ARCH_SUFFIX)_m16 endif ifdef CONFIG_HAS_SPE_FPU TARGET_SUFFIX:=$(TARGET_SUFFIX)spe |