diff options
author | nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2010-01-22 08:12:20 +0000 |
---|---|---|
committer | nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2010-01-22 08:12:20 +0000 |
commit | 1bf76dc757de04d31e3f2efec35f62aee1f2de22 (patch) | |
tree | 6e8a2f6dd9c606a4c1c4f395b4ac7d693b14ba2f | |
parent | 3a27cd7fac63f7a45751394922d1ed9465500de0 (diff) |
add a config item to specify arguments to strip
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19270 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Config.in | 9 | ||||
-rw-r--r-- | rules.mk | 2 |
2 files changed, 10 insertions, 1 deletions
@@ -173,6 +173,15 @@ choice endchoice +config STRIP_ARGS + string + prompt "Strip arguments" + depends USE_STRIP + default "--strip-unneeded --remove-section=.comment --remove-section=.note" if DEBUG + default "--strip-all" + help + Specifies arguments passed to the strip command when stripping binaries + config USE_MKLIBS bool "Strip unnecessary functions from libraries" help @@ -174,7 +174,7 @@ ifneq ($(CONFIG_NO_STRIP),) STRIP:=: else ifneq ($(CONFIG_USE_STRIP),) - STRIP:=$(TARGET_CROSS)strip + STRIP:=$(TARGET_CROSS)strip $(call qstrip,$(CONFIG_STRIP_ARGS)) else ifneq ($(CONFIG_USE_SSTRIP),) STRIP:=$(STAGING_DIR_HOST)/bin/sstrip |