summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-25 03:12:26 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-25 03:12:26 +0000
commit9cfeeb611a4ab9d58a06ee952529a76d1c1880ca (patch)
treefbf8c0e8ac87ac78bc205259645f49234833ab0f
parentf779fcc6a0cfd7f121f51de6f9cdd8fcb155bfbd (diff)
backport from whiterussian [1371]
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2301 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--openwrt/package/arptables/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/openwrt/package/arptables/Makefile b/openwrt/package/arptables/Makefile
index ceb745040b..f024e7db15 100644
--- a/openwrt/package/arptables/Makefile
+++ b/openwrt/package/arptables/Makefile
@@ -21,10 +21,12 @@ $(PKG_BUILD_DIR)/.configured:
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
- CFLAGS="$(TARGET_CFLAGS) -Wall -I$(PKG_BUILD_DIR)/include/linux/include -I$(PKG_BUILD_DIR)/include -DARPTABLES_VERSION=\\\"$(PKG_VERSION)\\\" "
+ COPT_FLAGS="$(TARGET_CFLAGS)" \
+ KERNEL_DIR="./include/linux"
touch $@
$(IPKG_ARPTABLES):
- mkdir -p $(IDIR_ARPTABLES)/usr/sbin
- cp $(PKG_BUILD_DIR)/arptables $(IDIR_ARPTABLES)/usr/sbin/
+ install -d -m0755 $(IDIR_ARPTABLES)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/arptables $(IDIR_ARPTABLES)/usr/sbin/
+ $(RSTRIP) $(IDIR_ARPTABLES)
$(IPKG_BUILD) $(IDIR_ARPTABLES) $(PACKAGE_DIR)