diff options
author | luka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2013-10-23 22:16:10 +0000 |
---|---|---|
committer | luka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2013-10-23 22:16:10 +0000 |
commit | 87dfe307f14112c6ba0a933589b73c5f54fe6e98 (patch) | |
tree | fc20b4179e404286ac4a67c2d66916674a4154c0 | |
parent | ff63df89bf6b74bec3187e43b3163e5873f0f9db (diff) |
Config.in: add more options when it comes to including kernel image into rootfs
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38517 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Config.in | 26 |
1 files changed, 25 insertions, 1 deletions
@@ -173,7 +173,7 @@ menu "Target Images" help Allows you to change the percentage of reserved blocks in the root filesystem - config TARGET_ROOTFS_INCLUDE_KERNEL + menuconfig TARGET_ROOTFS_INCLUDE_KERNEL bool "Include kernel in root filesystem" depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS default n if USES_UBIFS @@ -181,6 +181,30 @@ menu "Target Images" Include the kernel image in the rootfs. Typically the image is placed below /boot. + config TARGET_ROOTFS_INCLUDE_UIMAGE + bool "include uImage" if TARGET_ROOTFS_INCLUDE_KERNEL + default y + help + This option might not apply to all targets. Make sure + to check target/linux/<your_target>/image/Makefile to + see if this option will have any effect. + + config TARGET_ROOTFS_INCLUDE_ZIMAGE + bool "include zImage" if TARGET_ROOTFS_INCLUDE_KERNEL + default y + help + This option might not apply to all targets. Make sure + to check target/linux/<your_target>/image/Makefile to + see if this option will have any effect. + + config TARGET_ROOTFS_INCLUDE_FIT + bool "include FIT" if TARGET_ROOTFS_INCLUDE_KERNEL + default y + help + This option might not apply to all targets. Make sure + to check target/linux/<your_target>/image/Makefile to + see if this option will have any effect. + config TARGET_ROOTFS_INCLUDE_DTB bool "Include DTB in root filesystem" depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS |