summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-01 18:33:22 +0000
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-01 18:33:22 +0000
commit5d1d367be140498a005f396f674d1f76ecea6c00 (patch)
treeefc6f300a5be607004af1e9a37af3cd9b60f891f
parent377c94cf52f33c54c65eaae32b7b5b64f7b5dea8 (diff)
ar71xx: image: add IMAGE_PROFILE variable
Ensures that the 'Default' images are generated even if the subtarget has no profiles. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38635 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f2b6befa8e..316f8bd589 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -7,6 +7,8 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+IMAGE_PROFILE:=$(if $(PROFILE),$(PROFILE),Default)
+
JFFS2_BLOCKSIZE = 64k 128k 256k
define imgname
@@ -1010,7 +1012,7 @@ define Image/Build/squashfs
endef
define Image/Build/Initramfs
- $(call Image/Build/Profile/$(PROFILE),initramfs)
+ $(call Image/Build/Profile/$(IMAGE_PROFILE),initramfs)
endef
define Image/Prepare
@@ -1022,13 +1024,13 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
$(call Image/BuildLoader,generic,elf,,,-initramfs)
endif
$(call Image/BuildLoader,generic,elf)
- $(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(PROFILE)),loader)
+ $(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(IMAGE_PROFILE)),loader)
endef
define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
- $(call Image/Build/Profile/$(PROFILE),$(1))
+ $(call Image/Build/Profile/$(IMAGE_PROFILE),$(1))
endef
$(eval $(call BuildImage))