summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-08 14:08:21 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-08 14:08:21 +0000
commit378a18c0f3a8019d44c457f2f06e848a694714b0 (patch)
tree96e55d302e5bf6c831212681f9aef161397a3f4c
parenta8b7ca268e49ec9ed9540c7cf9f026112594f8c2 (diff)
Removed init script as there is an hotplug one, check whether user configuration directive is properly set, change the numbering to 10 rather than 15
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3189 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--openwrt/package/ez-ipupdate/Makefile2
-rw-r--r--openwrt/package/ez-ipupdate/files/ez-ipupdate.hotplug7
2 files changed, 7 insertions, 2 deletions
diff --git a/openwrt/package/ez-ipupdate/Makefile b/openwrt/package/ez-ipupdate/Makefile
index 66a25d934c..ce2583a4b5 100644
--- a/openwrt/package/ez-ipupdate/Makefile
+++ b/openwrt/package/ez-ipupdate/Makefile
@@ -50,7 +50,7 @@ $(IPKG_EZIPUPDATE):
install -m0755 $(PKG_BUILD_DIR)/ez-ipupdate $(IDIR_EZIPUPDATE)/usr/sbin/
install -m0755 files/$(PKG_NAME).init $(IDIR_EZIPUPDATE)/etc/init.d/S80$(PKG_NAME)
install -m0755 files/$(PKG_NAME).conf $(IDIR_EZIPUPDATE)/etc/
- install -m0755 files/$(PKG_NAME).hotplug $(IDIR_EZIPUPDATE)/etc/hotplug.d/iface/15-$(PKG_NAME)
+ install -m0755 files/$(PKG_NAME).hotplug $(IDIR_EZIPUPDATE)/etc/hotplug.d/iface/10-$(PKG_NAME)
$(STRIP) $(IDIR_EZIPUPDATE)/usr/sbin/*
$(IPKG_BUILD) $(IDIR_EZIPUPDATE) $(PACKAGE_DIR)
diff --git a/openwrt/package/ez-ipupdate/files/ez-ipupdate.hotplug b/openwrt/package/ez-ipupdate/files/ez-ipupdate.hotplug
index 3f27c140af..56a054b4ac 100644
--- a/openwrt/package/ez-ipupdate/files/ez-ipupdate.hotplug
+++ b/openwrt/package/ez-ipupdate/files/ez-ipupdate.hotplug
@@ -1 +1,6 @@
-[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && /usr/sbin/ez-ipupdate -c /etc/ez-ipupdate.conf &
+PGM=ez-ipupdate
+[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && {
+ [ -e /etc/$PGM.conf ] && {
+ [ -n $(grep "user=" /etc/$PGM.conf | cut -d= -f2 | cut -d: -f1) ] && [ -n $(grep "user=" /etc/$PGM.conf | cut -d= -f2 | cut -d: -f2) ] && /usr/sbin/$PGM -c /etc/$PGM.conf &
+ }
+}