[x86] GZip only ext4 and padded images
authoracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 16 Feb 2012 17:54:01 +0000 (17:54 +0000)
committeracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 16 Feb 2012 17:54:01 +0000 (17:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30588 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86/image/Config.in
target/linux/x86/image/Makefile

index ea3a13460a5924e7eeeffd97a758e8a1eb62338b..99054933e6625e8f1c0d9224dfad0777e10e9e76 100644 (file)
@@ -82,6 +82,7 @@ config TARGET_IMAGES_PAD
 
 config TARGET_IMAGES_GZIP
        bool "GZip images"
+       depends TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS
        default y
 
 config TARGET_KERNEL_PARTSIZE
index e52c74919d8c43d55b9f073829104245eaac3a40..6db12fca1ccf6c907874112f5d3adabe3d453b83 100644 (file)
@@ -176,12 +176,14 @@ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
   define Image/Build/gzip/ext4
        $(call Image/Build/gzip,ext4)
   endef
-  define Image/Build/gzip/jffs2-64k
+  ifneq ($(CONFIG_TARGET_IMAGES_PAD),)
+    define Image/Build/gzip/jffs2-64k
        $(call Image/Build/gzip,jffs2-64k)
-  endef
-  define Image/Build/gzip/jffs2-128k
+    endef
+    define Image/Build/gzip/jffs2-128k
        $(call Image/Build/gzip,jffs2-128k)
-  endef
+    endef
+  endif
 endif
 
 define Image/BuildKernel