[tools] use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt.git] / tools / patch-cmdline / Makefile
index cc6b9d3819da400f5c7c350e2da9f4cbc321eb1a..a9526397f1327d1388471a0ad29808df4bb19607 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,15 +10,15 @@ PKG_NAME:=patch-cmdline
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Compile
-       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -o $(PKG_BUILD_DIR)/$(PKG_NAME) src/$(PKG_NAME).c
+define Host/Compile
+       $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/$(PKG_NAME) src/$(PKG_NAME).c
 endef
 
-define Build/Install
-       $(CP) $(PKG_BUILD_DIR)/patch-cmdline $(STAGING_DIR_HOST)/bin/
+define Host/Install
+       $(CP) $(HOST_BUILD_DIR)/patch-cmdline $(STAGING_DIR_HOST)/bin/
 endef
 
-define Build/Clean
+define Host/Clean
        rm -f $(STAGING_DIR_HOST)/bin/patch-cmdline
 endef