ramips: raeth: use the NUM_TX_DESC for the tx_skb array
[openwrt.git] / tools / automake / Makefile
index ee7966aeebd5e6d7bc6e79d2efd7fc796253f78b..c30a9900e613e5f527ff29f250b1c5c7b67c5faf 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,24 +15,17 @@ PKG_MD5SUM:=c2972c4d9b3e29c03d5f2af86249876f
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       $(call Host/Configure/Default,\
-               --datarootdir=$(STAGING_DIR_HOST)/share \
-       )
-endef
-
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
+HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
 
 define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) install
        mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
        $(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
-       ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
-       ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
-       ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
-       ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.1
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.1
 endef
 
 define Host/Clean