ubifs: enable building modular images
[openwrt.git] / target / linux / xburst / image / Makefile
index 9c03b38092317fa48a16bf887cd0a6c0cc10c434..0de5560c961e0ee3f96486b6f2ab468d3d8943ec 100644 (file)
@@ -10,11 +10,11 @@ include $(INCLUDE_DIR)/image.mk
 JFFS2_BLOCKSIZE=256k 512k
 
 ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
+UBI_OPTS = -m 4096 -p 512KiB
 UBIFS_OPTS = -m 4096 -e 516096 -c 4095
-UBINIZE_OPTS = -m 4096 -p 512KiB
 else
+UBI_OPTS = -m 2048 -p 128KiB -s 512
 UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
-UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
 endif
 
 UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin