[x86 net5501: make kmod-leds-net5501 work
[openwrt.git] / target / linux / x86 / Makefile
index d1f0f70a01f11af4ce6ed916fa4d01f90fcd5044..fb365dd8ea9c7b2e3b11a1538125e0475d1c4131 100644 (file)
@@ -1,21 +1,22 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi vmdk tgz
-SUBTARGETS=generic
+FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
 
-LINUX_VERSION:=2.6.28.10
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+
+KERNELNAME:=bzImage
 
 $(eval $(call BuildTarget))