Add image generation for ar525w
[openwrt.git] / target / linux / rdc-2.6 / Makefile
index 3d48de7f5d73eb7fa6bc6ed3d81b5804a28f1caa..3fbd700c347539014e34e3f823c8fc243e194152 100644 (file)
@@ -16,9 +16,16 @@ define Target/Description
         (e.g. Airlink101 AR525W)
 endef
 
-LINUX_VERSION:=2.6.17
+LINUX_VERSION:=2.6.19.1
 LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+define Profile/Ralink
+  NAME:=Ralink WiFi (default)
+  PACKAGES:=kmod-rt61
+endef
+$(eval $(call Profile,Ralink))
+
 $(eval $(call BuildKernel))