Add image generation for ar525w
[openwrt.git] / target / linux / rdc-2.6 / Makefile
index 323eb2c3f4103b8cfc2e6af7356d1db94a166084..3fbd700c347539014e34e3f823c8fc243e194152 100644 (file)
@@ -6,9 +6,26 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
+ARCH:=i386
+BOARD:=rdc
+BOARDNAME:=RDC x86
+FEATURES:=broken jffs2
+
+define Target/Description
+        Build firmware images for RDC3211 based routers
+        (e.g. Airlink101 AR525W)
+endef
+
+LINUX_VERSION:=2.6.19.1
 LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+define Profile/Ralink
+  NAME:=Ralink WiFi (default)
+  PACKAGES:=kmod-rt61
+endef
+$(eval $(call Profile,Ralink))
+
 $(eval $(call BuildKernel))