ssb: Workaround: Need subsys_initcall to be able to register a PCI bus.
[openwrt.git] / target / linux / rdc / Makefile
index ac49adeb97482b715a7600b94a1ddf9d268d2712..4e83e163d74acd4eb50589b9ceef7abfb331808b 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC321x x86
-FEATURES:=squashfs jffs2 broken
+FEATURES:=squashfs jffs2 pci
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -32,7 +32,4 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   endef
 endif
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))