[rdc] provide the correct flash mapping on non airlink devices, remove the rootfs_typ...
[openwrt.git] / target / linux / rdc / Makefile
index 86265c38a1a01751408ec6a43b7c6459af8152ca..0abff003978635ae89a5ebdaeebaa3d1b027412b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,14 +10,21 @@ ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC 321x
 FEATURES:=squashfs jffs2 pci usb
+CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
 
-LINUX_VERSION:=2.6.24.7
+LINUX_VERSION:=2.6.30.9
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += hostapd-mini kmod-rdc321x-wdt
+
 define Target/Description
         Build firmware images for RDC321x based routers
         (e.g. Airlink101 AR525W, Linksys WRT54GR, Sitecom WL-153)
 endef
 
 $(eval $(call BuildTarget))
+
+$(eval $(call RequireCommand,lzma, \
+        Please install lzma-4.4x. \
+))