ramips: raeth: cleanup DMA API usage in ramips_eth_hard_start_xmit
[openwrt.git] / target / linux / ramips / Makefile
index be1d122f5b4ad5b99c69b3c24c129c2d79013ac5..c9dc086ee9c8d65fd6fe11481a6a0173de620d38 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +10,15 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT305x
 SUBTARGETS:=rt288x rt305x
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-FEATURES:=squashfs broken
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.32.9
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=kmod-leds-gpio
+DEFAULT_PACKAGES+=\
+       kmod-leds-gpio kmod-input-core kmod-input-polldev kmod-input-gpio-buttons \
+       kmod-button-hotplug kmod-rt2800-pci wpad-mini maccalc
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT305x based boards.