mpc85xx: add input drivers to default packages, and load those during preinit
[openwrt.git] / target / linux / mpc85xx / Makefile
index 3950c6ddcc13eb7a747d1a84840c8d777d45fa8d..feaa3bc7317a04a11e439b46bf50af17b52e9f25 100644 (file)
@@ -13,11 +13,13 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu ramdisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.8
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-booke-wdt
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-booke-wdt
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.