brcm47xx: bgmac: allow bigger et_swtype nvram variable
[openwrt.git] / target / linux / mpc85xx / Makefile
index 92064d0dcabfa8c5ff83f1fe1c5e4d830bfee140..93ba2c6143df7cc1ddd43e9cbaf12aa3c8f289f6 100644 (file)
@@ -9,17 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
+CFLAGS:=-Os -pipe -mcpu=8540
 FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.10.10
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-booke-wdt swconfig
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.