mpc52xx: switch to 3.8
[openwrt.git] / target / linux / mpc85xx / Makefile
index a7d4330c65f3d592bcb32e151104d2d3fc783988..19dff42ab3cec343c4b44fc2207e16485f1558a5 100644 (file)
@@ -10,14 +10,17 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.8.2
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-booke-wdt
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.