mpc52xx: switch to 3.8
[openwrt.git] / target / linux / mpc85xx / Makefile
index a441acf238de30cac990e604ce893cfe5858aae7..19dff42ab3cec343c4b44fc2207e16485f1558a5 100644 (file)
@@ -9,14 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
-FEATURES:=fpu ramdisk broken
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=3.8.2
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig
+
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef