targets: prepare for supporting normal and initramfs images
[openwrt.git] / target / linux / mpc52xx / Makefile
index b4649e45c4b2fee3c4b2d5e6cd529f00c897d2f2..d3cf6a29503acbbe9dcdc62e469b3e2e80fdc612 100644 (file)
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc52xx
 BOARDNAME:=Freescale MPC52xx
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=603e
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=2.6.30.10
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -20,4 +20,6 @@ define Target/Description
        Build images for the Freescale MPC52xx based boards.
 endef
 
+KERNELNAME:="zImage"
+
 $(eval $(call BuildTarget))