omap24xx: bump to 3.1.3
[openwrt.git] / target / linux / lantiq / patches / 211-devices.patch
index a5561c788ecff0222c83bc78cae24570ee39b40e..eefb9c9dade12b9bc51ac34f9fcf291ba15d9592 100644 (file)
@@ -1,7 +1,7 @@
-Index: linux-3.1/arch/mips/lantiq/devices.c
+Index: linux-3.1.1/arch/mips/lantiq/devices.c
 ===================================================================
---- linux-3.1.orig/arch/mips/lantiq/devices.c  2011-11-12 18:06:54.712192370 +0100
-+++ linux-3.1/arch/mips/lantiq/devices.c       2011-11-12 18:06:55.544192390 +0100
+--- linux-3.1.1.orig/arch/mips/lantiq/devices.c        2011-11-14 20:22:33.588135463 +0100
++++ linux-3.1.1/arch/mips/lantiq/devices.c     2011-11-14 20:22:34.328135495 +0100
 @@ -18,6 +18,7 @@
  #include <linux/time.h>
  #include <linux/io.h>
@@ -31,10 +31,10 @@ Index: linux-3.1/arch/mips/lantiq/devices.c
 +      cp1_base =
 +              (void*)CPHYSADDR(dma_alloc_coherent(NULL, CP1_SIZE, &dma, GFP_ATOMIC));
 +}
-Index: linux-3.1/arch/mips/lantiq/devices.h
+Index: linux-3.1.1/arch/mips/lantiq/devices.h
 ===================================================================
---- linux-3.1.orig/arch/mips/lantiq/devices.h  2011-11-12 18:06:54.712192370 +0100
-+++ linux-3.1/arch/mips/lantiq/devices.h       2011-11-12 18:06:55.544192390 +0100
+--- linux-3.1.1.orig/arch/mips/lantiq/devices.h        2011-11-14 20:22:33.588135463 +0100
++++ linux-3.1.1/arch/mips/lantiq/devices.h     2011-11-14 20:22:34.328135495 +0100
 @@ -23,5 +23,6 @@
  extern void ltq_register_wdt(void);
  extern void ltq_register_asc(int port);
@@ -42,22 +42,22 @@ Index: linux-3.1/arch/mips/lantiq/devices.h
 +extern void ltq_register_tapi(void);
  
  #endif
-Index: linux-3.1/arch/mips/lantiq/xway/Makefile
+Index: linux-3.1.1/arch/mips/lantiq/xway/Makefile
 ===================================================================
---- linux-3.1.orig/arch/mips/lantiq/xway/Makefile      2011-11-12 18:06:55.520192389 +0100
-+++ linux-3.1/arch/mips/lantiq/xway/Makefile   2011-11-12 18:06:55.544192390 +0100
+--- linux-3.1.1.orig/arch/mips/lantiq/xway/Makefile    2011-11-14 20:22:34.304135491 +0100
++++ linux-3.1.1/arch/mips/lantiq/xway/Makefile 2011-11-14 20:39:51.404179655 +0100
 @@ -1,5 +1,7 @@
  obj-y := sysctrl.o reset.o gpio.o gpio_stp.o gpio_ebu.o devices.o dma.o nand.o timer.o
  
-+obj-y += dev-dwc_otg.o
++obj-y += dev-dwc_otg.o dev-wifi-rt2x00.o dev-wifi-ath5k.o
 +
  obj-$(CONFIG_SOC_XWAY) += clk-xway.o prom-xway.o
  obj-$(CONFIG_SOC_AMAZON_SE) += clk-ase.o prom-ase.o
  obj-$(CONFIG_SOC_VR9) += clk-vr9.o prom-vr9.o
-Index: linux-3.1/arch/mips/lantiq/xway/devices.c
+Index: linux-3.1.1/arch/mips/lantiq/xway/devices.c
 ===================================================================
---- linux-3.1.orig/arch/mips/lantiq/xway/devices.c     2011-11-12 18:06:55.304192384 +0100
-+++ linux-3.1/arch/mips/lantiq/xway/devices.c  2011-11-12 18:06:55.544192390 +0100
+--- linux-3.1.1.orig/arch/mips/lantiq/xway/devices.c   2011-11-14 20:22:34.092135483 +0100
++++ linux-3.1.1/arch/mips/lantiq/xway/devices.c        2011-11-14 20:22:34.328135495 +0100
 @@ -19,6 +19,7 @@
  #include <linux/time.h>
  #include <linux/io.h>
@@ -165,10 +165,10 @@ Index: linux-3.1/arch/mips/lantiq/xway/devices.c
 +      ltq_spi.dev.platform_data = pdata;
 +      platform_device_register(&ltq_spi);
 +}
-Index: linux-3.1/arch/mips/lantiq/xway/devices.h
+Index: linux-3.1.1/arch/mips/lantiq/xway/devices.h
 ===================================================================
---- linux-3.1.orig/arch/mips/lantiq/xway/devices.h     2011-10-24 09:10:05.000000000 +0200
-+++ linux-3.1/arch/mips/lantiq/xway/devices.h  2011-11-12 18:06:55.544192390 +0100
+--- linux-3.1.1.orig/arch/mips/lantiq/xway/devices.h   2011-11-11 21:19:27.000000000 +0100
++++ linux-3.1.1/arch/mips/lantiq/xway/devices.h        2011-11-14 20:22:34.328135495 +0100
 @@ -11,10 +11,17 @@
  
  #include "../devices.h"
@@ -187,16 +187,16 @@ Index: linux-3.1/arch/mips/lantiq/xway/devices.h
 +extern void ltq_register_gpio_buttons(struct gpio_button *buttons, int cnt);
  
  #endif
-Index: linux-3.1/arch/mips/lantiq/Makefile
+Index: linux-3.1.1/arch/mips/lantiq/Makefile
 ===================================================================
---- linux-3.1.orig/arch/mips/lantiq/Makefile   2011-11-12 18:06:54.780192371 +0100
-+++ linux-3.1/arch/mips/lantiq/Makefile        2011-11-12 19:52:32.700339384 +0100
+--- linux-3.1.1.orig/arch/mips/lantiq/Makefile 2011-11-14 20:22:33.640135462 +0100
++++ linux-3.1.1/arch/mips/lantiq/Makefile      2011-11-14 20:39:09.852178049 +0100
 @@ -4,7 +4,7 @@
  # under the terms of the GNU General Public License version 2 as published
  # by the Free Software Foundation.
  
 -obj-y := irq.o setup.o clk.o prom.o devices.o
-+obj-y := irq.o setup.o clk.o prom.o devices.o dev-gpio-leds.o dev-gpio-buttons.o dev-wifi-rt2x00.o
++obj-y := irq.o setup.o clk.o prom.o devices.o dev-gpio-leds.o dev-gpio-buttons.o
  
  obj-$(CONFIG_EARLY_PRINTK) += early_printk.o