ath9k: merge a few bugfixes
[openwrt.git] / target / linux / lantiq / Makefile
index 309b31a1648e746d96b33215bab807a2c8ffaa0d..fa74e95af8e3e1b0ca48b248c81cfa9bbaca6647 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=lantiq
 BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2 atm
-SUBTARGETS:=xway
+FEATURES:=squashfs jffs2
+SUBTARGETS:=falcon xway
 
-LINUX_VERSION:=2.6.35.11
+LINUX_VERSION:=2.6.37.6
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 
 include $(INCLUDE_DIR)/target.mk