kernel: update 3.10 to 3.10.36
[openwrt.git] / target / linux / lantiq / Makefile
index 412b7b19c66ed3ac83e4696bf1b0c80391f5694c..65839eb274481539756e6267698996ce04b8f2eb 100644 (file)
@@ -6,21 +6,19 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway ase
+BOARDNAME:=Lantiq
+FEATURES:=squashfs ubifs
+SUBTARGETS=xway xrx200
 
-LINUX_VERSION:=2.6.39
-#LINUX_VERSION:=2.6.32.33
+LINUX_VERSION:=3.10.36
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-
-include $(INCLUDE_DIR)/target.mk
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))