fix broken falcon patches from last night
[openwrt.git] / target / linux / lantiq / Makefile
index dfaccbb830925a029ec7e7947d88e03bb500d683..0f5064c3fc5f881549609f4e73a6eaf7b78a591e 100644 (file)
@@ -10,16 +10,16 @@ ARCH:=mips
 BOARD:=lantiq
 BOARDNAME:=Lantiq GPON/XWAY
 FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway
+#SUBTARGETS:=xway falcon ase
 
-LINUX_VERSION:=2.6.37.4
+LINUX_VERSION:=2.6.39.2
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-
-include $(INCLUDE_DIR)/target.mk
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))