ixp4xx/apex: Limit ram size to 64MB
[openwrt.git] / target / linux / ixp4xx / patches-2.6.26 / 130-wrt300nv2_support.patch
index b797cb425cb22b72892cb912920f751033df4d3d..7917240a655a85c5088ec0cb955089e0376713b6 100644 (file)
@@ -1,8 +1,8 @@
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -73,6 +73,14 @@
+@@ -97,6 +97,14 @@ config MACH_COMPEX
          WP18 or NP18A boards. For more information on this
-         platform, see http://openwrt.org
+         platform, see http://www.compex.com.sg/home/OEM/product_ap.htm
  
 +config MACH_WRT300NV2
 +      bool "Linksys WRT300N v2"
        help
 --- a/arch/arm/mach-ixp4xx/Makefile
 +++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -18,6 +18,7 @@
- obj-pci-$(CONFIG_MACH_FSG)            += fsg-pci.o
- obj-pci-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-pci.o
+@@ -20,6 +20,7 @@ obj-pci-$(CONFIG_MACH_FSG)           += fsg-pci.o
+ obj-pci-$(CONFIG_MACH_PRONGHORN)      += pronghorn-pci.o
+ obj-pci-$(CONFIG_MACH_SIDEWINDER)     += sidewinder-pci.o
  obj-pci-$(CONFIG_MACH_COMPEX)         += ixdp425-pci.o
 +obj-pci-$(CONFIG_MACH_WRT300NV2)              += wrt300nv2-pci.o
  
  obj-y += common.o
  
-@@ -34,6 +35,7 @@
- obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
- obj-$(CONFIG_MACH_PRONGHORNMETRO)     += pronghornmetro-setup.o
+@@ -38,6 +39,7 @@ obj-$(CONFIG_MACH_FSG)               += fsg-setup.o
+ obj-$(CONFIG_MACH_PRONGHORN)  += pronghorn-setup.o
+ obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
  obj-$(CONFIG_MACH_COMPEX)     += compex-setup.o
 +obj-$(CONFIG_MACH_WRT300NV2)  += wrt300nv2-setup.o
  
 +#endif
 --- a/include/asm-arm/arch-ixp4xx/uncompress.h
 +++ b/include/asm-arm/arch-ixp4xx/uncompress.h
-@@ -42,7 +42,7 @@
+@@ -42,7 +42,7 @@ static __inline__ void __arch_decomp_set
         */
        if (machine_is_adi_coyote() || machine_is_gtwx5715() ||
                         machine_is_gateway7001() || machine_is_wg302v2() ||
--                       machine_is_pronghorn_metro())
-+                       machine_is_pronghorn_metro() || machine_is_wrt300nv2())
+-                       machine_is_pronghorn() || machine_is_pronghorn_metro())
++                       machine_is_pronghorn() || machine_is_pronghorn_metro() || machine_is_wrt300nv2())
                uart_base = (volatile u32*) IXP4XX_UART2_BASE_PHYS;
        else
                uart_base = (volatile u32*) IXP4XX_UART1_BASE_PHYS;