[ixp4xx] move the latch-led driver into a separated patch
[openwrt.git] / target / linux / ixp4xx / patches / 300-wg302v2.patch
index 8dc1d72d9e59dd36e71fa0dd5635142bee80713e..e0f0c21f69484d2b26dbb85193e842832e672a65 100644 (file)
@@ -1,7 +1,8 @@
-diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/Kconfig linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Kconfig
---- linux-2.6.19.2/arch/arm/mach-ixp4xx/Kconfig        2007-04-02 16:09:06.000000000 +0200
-+++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Kconfig   2007-04-02 16:01:25.000000000 +0200
-@@ -41,6 +41,14 @@
+Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/Kconfig
+===================================================================
+--- linux-2.6.21.7.orig/arch/arm/mach-ixp4xx/Kconfig
++++ linux-2.6.21.7/arch/arm/mach-ixp4xx/Kconfig
+@@ -49,6 +49,14 @@ config MACH_GATEWAY7001
          7001 Access Point. For more information on this platform,
          see http://openwrt.org
  
@@ -16,27 +17,29 @@ diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/Kconfig linux-2.6.19.2-owrt/arch/a
  config ARCH_IXDP425
        bool "IXDP425"
        help
-diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/Makefile linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Makefile
---- linux-2.6.19.2/arch/arm/mach-ixp4xx/Makefile       2007-04-02 16:09:06.000000000 +0200
-+++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Makefile  2007-04-02 16:09:25.000000000 +0200
-@@ -12,6 +12,7 @@
- obj-pci-$(CONFIG_MACH_NSLU2)          += nslu2-pci.o
+Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/Makefile
+===================================================================
+--- linux-2.6.21.7.orig/arch/arm/mach-ixp4xx/Makefile
++++ linux-2.6.21.7/arch/arm/mach-ixp4xx/Makefile
+@@ -14,6 +14,7 @@ obj-pci-$(CONFIG_MACH_NSLU2)         += nslu2-p
  obj-pci-$(CONFIG_MACH_NAS100D)                += nas100d-pci.o
+ obj-pci-$(CONFIG_MACH_DSMG600)                += dsmg600-pci.o
  obj-pci-$(CONFIG_MACH_GATEWAY7001)    += gateway7001-pci.o
 +obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
  
  obj-y += common.o
  
-@@ -22,5 +23,6 @@
- obj-$(CONFIG_MACH_NSLU2)      += nslu2-setup.o nslu2-power.o
+@@ -26,5 +27,6 @@ obj-$(CONFIG_MACH_NSLU2)     += nslu2-setup.
  obj-$(CONFIG_MACH_NAS100D)    += nas100d-setup.o nas100d-power.o
+ obj-$(CONFIG_MACH_DSMG600)      += dsmg600-setup.o dsmg600-power.o
  obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-setup.o
 +obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
-diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-pci.c linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/wg302v2-pci.c
---- linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-pci.c  1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/wg302v2-pci.c     2007-04-02 16:00:12.000000000 +0200
+Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/wg302v2-pci.c
+===================================================================
+--- /dev/null
++++ linux-2.6.21.7/arch/arm/mach-ixp4xx/wg302v2-pci.c
 @@ -0,0 +1,68 @@
 +/*
 + * arch/arch/mach-ixp4xx/wg302v2-pci.c
@@ -106,9 +109,10 @@ diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-pci.c linux-2.6.19.2-owrt/
 +}
 +
 +subsys_initcall(wg302v2_pci_init);
-diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-setup.c linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/wg302v2-setup.c
---- linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-setup.c        1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/wg302v2-setup.c   2007-04-02 16:08:57.000000000 +0200
+Index: linux-2.6.21.7/arch/arm/mach-ixp4xx/wg302v2-setup.c
+===================================================================
+--- /dev/null
++++ linux-2.6.21.7/arch/arm/mach-ixp4xx/wg302v2-setup.c
 @@ -0,0 +1,107 @@
 +/*
 + * arch/arm/mach-ixp4xx/wg302-setup.c
@@ -217,10 +221,11 @@ diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-setup.c linux-2.6.19.2-owr
 +      .init_machine   = wg302v2_init,
 +MACHINE_END
 +#endif
-diff -Nur linux-2.6.19.2/include/asm-arm/arch-ixp4xx/uncompress.h linux-2.6.19.2-owrt/include/asm-arm/arch-ixp4xx/uncompress.h
---- linux-2.6.19.2/include/asm-arm/arch-ixp4xx/uncompress.h    2007-04-02 16:09:06.000000000 +0200
-+++ linux-2.6.19.2-owrt/include/asm-arm/arch-ixp4xx/uncompress.h       2007-04-02 16:02:04.000000000 +0200
-@@ -40,7 +40,7 @@
+Index: linux-2.6.21.7/include/asm-arm/arch-ixp4xx/uncompress.h
+===================================================================
+--- linux-2.6.21.7.orig/include/asm-arm/arch-ixp4xx/uncompress.h
++++ linux-2.6.21.7/include/asm-arm/arch-ixp4xx/uncompress.h
+@@ -40,7 +40,7 @@ static __inline__ void __arch_decomp_set
        /*
         * Some boards are using UART2 as console
         */