update other 2.6.28.7 targets to 2.6.28.8, too
[openwrt.git] / target / linux / ifxmips / Makefile
index a42b32792141a4a58b8d0d4d1d23e84c2318453a..81bfd2e9bc90c43ab784c52fa3702f8dbac59546 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +10,21 @@ ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.26.8
+
+LINUX_VERSION:=2.6.28.8
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips
+DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers
 endef
 
+ifeq ($(KERNEL_PATCHVER),2.6.28)
+  define Kernel/Prepare
+       $(call Kernel/Prepare/Default)
+       mv $(LINUX_DIR)/include/asm-mips/* $(LINUX_DIR)/arch/mips/include/asm/
+  endef
+endif
+
 $(eval $(call BuildTarget))