add generic 2.6.28 patches
[openwrt.git] / target / linux / generic-2.6 / patches-2.6.25 / 640-mvswitch.patch
index 62c64baef3018a4eae85da97a02b0cf0a38fbcc2..c2d7d1c0de51e782b6559619ac8e1b1c24341215 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.25.4/drivers/net/phy/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/phy/Kconfig
-+++ linux-2.6.25.4/drivers/net/phy/Kconfig
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
 @@ -70,6 +70,12 @@ config ADM6996_PHY
        ---help---
          Currently supports the ADM6996F switch
@@ -15,10 +13,8 @@ Index: linux-2.6.25.4/drivers/net/phy/Kconfig
  config FIXED_PHY
        bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
        depends on PHYLIB=y
-Index: linux-2.6.25.4/drivers/net/phy/Makefile
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/phy/Makefile
-+++ linux-2.6.25.4/drivers/net/phy/Makefile
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
 @@ -13,6 +13,7 @@ obj-$(CONFIG_VITESSE_PHY)    += vitesse.o
  obj-$(CONFIG_BROADCOM_PHY)    += broadcom.o
  obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
@@ -27,10 +23,8 @@ Index: linux-2.6.25.4/drivers/net/phy/Makefile
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o
  obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o
-Index: linux-2.6.25.4/drivers/net/phy/mdio_bus.c
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/phy/mdio_bus.c
-+++ linux-2.6.25.4/drivers/net/phy/mdio_bus.c
+--- a/drivers/net/phy/mdio_bus.c
++++ b/drivers/net/phy/mdio_bus.c
 @@ -35,6 +35,12 @@
  #include <asm/irq.h>
  #include <asm/uaccess.h>