add thermal symbol to the generic .25 config
[openwrt.git] / target / linux / generic-2.6 / patches-2.6.24 / 171-netfilter_tarpit.patch
index 058dda5c2887a2153e7d3974355c5950585b32c9..2ebb669573969728d1cf95daf37600e1c169940c 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.23/net/netfilter/Kconfig
-===================================================================
---- linux-2.6.23.orig/net/netfilter/Kconfig
-+++ linux-2.6.23/net/netfilter/Kconfig
-@@ -401,6 +401,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
+--- a/net/netfilter/Kconfig
++++ b/net/netfilter/Kconfig
+@@ -401,6 +401,23 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -26,23 +24,19 @@ Index: linux-2.6.23/net/netfilter/Kconfig
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
        depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.23/net/netfilter/Makefile
-===================================================================
---- linux-2.6.23.orig/net/netfilter/Makefile
-+++ linux-2.6.23/net/netfilter/Makefile
-@@ -49,6 +49,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG) 
+--- a/net/netfilter/Makefile
++++ b/net/netfilter/Makefile
+@@ -47,6 +47,7 @@
+ obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE) += xt_NFQUEUE.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
- obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK) += xt_SECMARK.o
 +obj-$(CONFIG_NETFILTER_XT_TARGET_TARPIT) += xt_TARPIT.o
  obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
- obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
-Index: linux-2.6.23/net/netfilter/xt_TARPIT.c
-===================================================================
+ obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
+ obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
 --- /dev/null
-+++ linux-2.6.23/net/netfilter/xt_TARPIT.c
-@@ -0,0 +1,280 @@
++++ b/net/netfilter/xt_TARPIT.c
+@@ -0,0 +1,279 @@
 +/*
 + * Kernel module to capture and hold incoming TCP connections using
 + * no local per-connection resources.
@@ -246,14 +240,13 @@ Index: linux-2.6.23/net/netfilter/xt_TARPIT.c
 +      kfree_skb(nskb);
 +}
 +
-+static unsigned int xt_tarpit_target(struct sk_buff **pskb,
++static unsigned int xt_tarpit_target(struct sk_buff *skb,
 +                                     const struct net_device *in,
 +                                     const struct net_device *out,
 +                                     unsigned int hooknum,
 +                                     const struct xt_target *target,
 +                                     const void *targinfo)
 +{
-+      const struct sk_buff *skb = *pskb;
 +      const struct iphdr *iph   = ip_hdr(skb);
 +      struct rtable *rt         = (void *)skb->dst;
 +