[kernel] generic: add missing PHY related config entries
[openwrt.git] / target / linux / generic-2.6 / patches-2.6.24 / 002-lzma_decompress.patch
index 9e75936f0f66b4bc6573fda3ff37246f7b71df3e..5ebf6999fe2c4d19c54d7617a9b05fff5b4eea1f 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.23/include/linux/LzmaDecode.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/include/linux/LzmaDecode.h    2007-10-10 13:51:27.000000000 +0800
+--- /dev/null
++++ b/include/linux/LzmaDecode.h
 @@ -0,0 +1,100 @@
 +/*
 +  LzmaDecode.h
@@ -103,10 +101,8 @@ Index: linux-2.6.23/include/linux/LzmaDecode.h
 +    UInt32 *outSizeProcessed);
 +
 +#endif
-Index: linux-2.6.23/lib/LzmaDecode.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/lib/LzmaDecode.c      2007-10-10 13:51:27.000000000 +0800
+--- /dev/null
++++ b/lib/LzmaDecode.c
 @@ -0,0 +1,663 @@
 +/*
 +  LzmaDecode.c
@@ -771,12 +767,10 @@ Index: linux-2.6.23/lib/LzmaDecode.c
 +  *outSizeProcessed = nowPos;
 +  return LZMA_RESULT_OK;
 +}
-Index: linux-2.6.23/lib/Makefile
-===================================================================
---- linux-2.6.23.orig/lib/Makefile     2007-10-10 13:50:24.000000000 +0800
-+++ linux-2.6.23/lib/Makefile  2007-10-10 13:51:53.000000000 +0800
-@@ -13,7 +13,7 @@
- lib-y += kobject.o kref.o kobject_uevent.o klist.o
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -14,7 +14,7 @@
+ lib-y += kobject.o kref.o klist.o
  
  obj-y += div64.o sort.o parser.o halfmd4.o debug_locks.o random32.o \
 -       bust_spinlocks.o hexdump.o kasprintf.o bitmap.o
@@ -784,7 +778,7 @@ Index: linux-2.6.23/lib/Makefile
  
  ifeq ($(CONFIG_DEBUG_KOBJECT),y)
  CFLAGS_kobject.o += -DDEBUG
-@@ -62,6 +62,7 @@
+@@ -64,6 +64,7 @@
  obj-$(CONFIG_AUDIT_GENERIC) += audit.o
  
  obj-$(CONFIG_SWIOTLB) += swiotlb.o