generic/3.10: remove unused defines from the rootfs split patch
[openwrt.git] / target / linux / generic / patches-3.6 / 321-powerpc_crtsavres_prereq.patch
index 941aa909de00e3f44cdcec04d58ef1b56bf10bef..fe5d7c576eab1f7cc8b984e43cb808c727f3a57b 100644 (file)
@@ -1,10 +1,10 @@
 --- a/arch/powerpc/Makefile
 +++ b/arch/powerpc/Makefile
-@@ -94,7 +94,6 @@ else
- endif
- endif
+@@ -86,7 +86,6 @@ CPP          = $(CC) -E $(KBUILD_CFLAGS)
+ CHECKFLAGS    += -m$(CONFIG_WORD_SIZE) -D__powerpc__ -D__powerpc$(CONFIG_WORD_SIZE)__
  
 -KBUILD_LDFLAGS_MODULE += arch/powerpc/lib/crtsavres.o
  
- ifeq ($(CONFIG_TUNE_CELL),y)
      KBUILD_CFLAGS += $(call cc-option,-mtune=cell)
+ # No AltiVec or VSX instructions when building kernel
KBUILD_CFLAGS += $(call cc-option,-mno-altivec)