kernel: fix arch-dependent bug in hso module
[openwrt.git] / target / linux / generic / patches-3.3 / 727-phy-rtl8367.patch
index 820bda0cdb207a06173235967163490c95979ebc..a24f497c9b2ec6b799b6726f14dd42642ac07c28 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -179,6 +179,10 @@ config RTL8366RB_PHY
+@@ -190,6 +190,10 @@ config RTL8366RB_PHY
        tristate "Driver for the Realtek RTL8366RB switch"
        select SWCONFIG
  
@@ -8,12 +8,12 @@
 +      tristate "Driver for the Realtek RTL8367R/M switches"
 +      select SWCONFIG
 +
- config RTL8366S_PHY_DEBUG_FS
-       bool "RTL8366 switch driver DEBUG_FS support"
-       depends on RTL8366S_PHY || RTL8366RB_PHY
+ endif # RTL8366_SMI
+ endif # PHYLIB
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_RTL8306_PHY)    += rtl8306.o
+@@ -25,6 +25,7 @@ obj-$(CONFIG_RTL8306_PHY)    += rtl8306.o
  obj-$(CONFIG_RTL8366_SMI)     += rtl8366_smi.o
  obj-$(CONFIG_RTL8366S_PHY)    += rtl8366s.o
  obj-$(CONFIG_RTL8366RB_PHY)   += rtl8366rb.o