kernel: strip unnecessary symbol table information from kernel modules, reduces defau...
[openwrt.git] / target / linux / generic / patches-3.2 / 202-reduce_module_size.patch
diff --git a/target/linux/generic/patches-3.2/202-reduce_module_size.patch b/target/linux/generic/patches-3.2/202-reduce_module_size.patch
new file mode 100644 (file)
index 0000000..58b4a75
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -374,7 +374,7 @@
+ KBUILD_AFLAGS   := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE  := -DMODULE
+ KBUILD_CFLAGS_MODULE  := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -s
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)