[etrax] refresh kernel patches
[openwrt.git] / target / linux / etrax / patches / 100-compile_fixes.patch
index 93e434c99d732280d6586fa745b4ec6c6c87ec54..0455f1f44744ded15b374ef3babf39a610dc1b76 100644 (file)
@@ -1,32 +1,7 @@
-Index: linux-2.6.25/arch/cris/mm/init.c
+Index: linux-2.6.25.4/arch/cris/arch-v10/boot/Makefile
 ===================================================================
---- linux-2.6.25.orig/arch/cris/mm/init.c      2008-05-03 09:53:53.000000000 +0100
-+++ linux-2.6.25/arch/cris/mm/init.c   2008-05-03 09:54:05.000000000 +0100
-@@ -112,3 +112,7 @@
-         printk (KERN_INFO "Freeing unused kernel memory: %luk freed\n",
-               (unsigned long)((&__init_end - &__init_begin) >> 10));
- }
-+
-+void free_initrd_mem(unsigned long start, unsigned long end)
-+{
-+}
-Index: linux-2.6.25/arch/cris/boot/compressed/Makefile
-===================================================================
---- linux-2.6.25.orig/arch/cris/boot/compressed/Makefile       2008-05-03 10:00:53.000000000 +0100
-+++ linux-2.6.25/arch/cris/boot/compressed/Makefile    2008-05-03 10:01:12.000000000 +0100
-@@ -7,7 +7,7 @@
- LD = ld-cris
- ldflags-y += -T $(obj)/decompress.ld
- OBJECTS = $(obj)/head.o $(obj)/misc.o
--OBJCOPY = objcopy-cris
-+OBJCOPY = /usr/local/cris/objcopy-cris
- OBJCOPYFLAGS = -O binary --remove-section=.bss
- quiet_cmd_image = BUILD   $@
-Index: linux-2.6.25/arch/cris/boot/Makefile
-===================================================================
---- linux-2.6.25.orig/arch/cris/boot/Makefile  2008-04-17 03:49:44.000000000 +0100
-+++ linux-2.6.25/arch/cris/boot/Makefile       2008-05-03 10:05:56.000000000 +0100
+--- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/Makefile
++++ linux-2.6.25.4/arch/cris/arch-v10/boot/Makefile
 @@ -2,10 +2,10 @@
  # arch/cris/arch-v10/boot/Makefile
  #
@@ -40,7 +15,7 @@ Index: linux-2.6.25/arch/cris/boot/Makefile
  targets := Image
  
  $(obj)/Image: vmlinux FORCE
-@@ -14,7 +14,6 @@
+@@ -14,7 +14,6 @@ $(obj)/Image: vmlinux FORCE
  
  $(obj)/compressed/vmlinux: $(obj)/Image FORCE
        $(Q)$(MAKE) $(build)=$(obj)/compressed $@
@@ -48,11 +23,11 @@ Index: linux-2.6.25/arch/cris/boot/Makefile
  
  $(obj)/zImage:  $(obj)/compressed/vmlinux
        @cp $< $@
-Index: linux-2.6.25/arch/cris/boot/compressed/Makefile
+Index: linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/Makefile
 ===================================================================
---- linux-2.6.25.orig/arch/cris/boot/compressed/Makefile       2008-05-03 10:01:12.000000000 +0100
-+++ linux-2.6.25/arch/cris/boot/compressed/Makefile    2008-05-03 16:29:55.000000000 +0100
-@@ -2,9 +2,8 @@
+--- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/compressed/Makefile
++++ linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/Makefile
+@@ -2,12 +2,11 @@
  # arch/cris/arch-v10/boot/compressed/Makefile
  #
  
@@ -62,8 +37,12 @@ Index: linux-2.6.25/arch/cris/boot/compressed/Makefile
 +LD=/usr/local/cris/ld-cris
  ldflags-y += -T $(obj)/decompress.ld
  OBJECTS = $(obj)/head.o $(obj)/misc.o
- OBJCOPY = /usr/local/cris/objcopy-cris
-@@ -22,10 +21,10 @@
+-OBJCOPY = objcopy-cris
++OBJCOPY = /usr/local/cris/objcopy-cris
+ OBJCOPYFLAGS = -O binary --remove-section=.bss
+ quiet_cmd_image = BUILD   $@
+@@ -22,10 +21,10 @@ $(obj)/decompress.bin: $(obj)/decompress
        $(call if_changed,objcopy)
  
  $(obj)/head.o: $(obj)/head.S .config
@@ -76,10 +55,10 @@ Index: linux-2.6.25/arch/cris/boot/compressed/Makefile
  
  $(obj)/vmlinux: $(obj)/piggy.gz $(obj)/decompress.bin FORCE
        $(call if_changed,image)
-Index: linux-2.6.25/arch/cris/boot/compressed/misc.c
+Index: linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/misc.c
 ===================================================================
---- linux-2.6.25.orig/arch/cris/boot/compressed/misc.c 2008-05-03 16:22:44.000000000 +0100
-+++ linux-2.6.25/arch/cris/boot/compressed/misc.c      2008-05-03 16:23:26.000000000 +0100
+--- linux-2.6.25.4.orig/arch/cris/arch-v10/boot/compressed/misc.c
++++ linux-2.6.25.4/arch/cris/arch-v10/boot/compressed/misc.c
 @@ -5,7 +5,7 @@
   * adapted for Linux.
   *
@@ -89,7 +68,7 @@ Index: linux-2.6.25/arch/cris/boot/compressed/misc.c
   * adaptation for Linux/CRIS Axis Communications AB, 1999
   *
   */
-@@ -99,7 +99,7 @@
+@@ -99,7 +99,7 @@ static void error(char *m);
  static void gzip_mark(void **);
  static void gzip_release(void **);
   
@@ -98,7 +77,7 @@ Index: linux-2.6.25/arch/cris/boot/compressed/misc.c
  
  /* the "heap" is put directly after the BSS ends, at end */
    
-@@ -139,7 +139,7 @@
+@@ -139,7 +139,7 @@ static void gzip_release(void **ptr)
  /* decompressor info and error messages to serial console */
  
  static void
@@ -107,7 +86,7 @@ Index: linux-2.6.25/arch/cris/boot/compressed/misc.c
  {
  #ifndef CONFIG_ETRAX_DEBUG_PORT_NULL
        while(*s) {
-@@ -209,9 +209,9 @@
+@@ -209,9 +209,9 @@ flush_window()
  static void
  error(char *x)
  {
@@ -120,7 +99,7 @@ Index: linux-2.6.25/arch/cris/boot/compressed/misc.c
  
        while(1);       /* Halt */
  }
-@@ -257,14 +257,7 @@
+@@ -257,14 +257,7 @@ decompress_kernel()
  
        makecrc();
  
@@ -137,3 +116,17 @@ Index: linux-2.6.25/arch/cris/boot/compressed/misc.c
 -      puts("Done. Now booting the kernel.\n");
 +      putstr("Done. Now booting the kernel.\n");
  }
+Index: linux-2.6.25.4/arch/cris/arch-v10/mm/init.c
+===================================================================
+--- linux-2.6.25.4.orig/arch/cris/arch-v10/mm/init.c
++++ linux-2.6.25.4/arch/cris/arch-v10/mm/init.c
+@@ -184,6 +184,9 @@ paging_init(void)
+       free_area_init_node(0, &contig_page_data, zones_size, PAGE_OFFSET >> PAGE_SHIFT, 0);
+ }
++void free_initrd_mem(unsigned long start, unsigned long end)
++{
++}
+ /* Initialize remaps of some I/O-ports. It is important that this
+  * is called before any driver is initialized.