[cns3xxx]: reorder, rename and refresh patches
[openwrt.git] / target / linux / cns3xxx / Makefile
index 45faa103c1ec2297b520e74df0d28fa8da827507..72e51fd51c0c6415c8be850afdb0ec8d81714fc3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,9 +10,10 @@ ARCH:=arm
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
 FEATURES:=squashfs fpu gpio
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
+CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.31.14
+LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -23,4 +24,6 @@ endef
 
 KERNELNAME:="uImage"
 
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
+
 $(eval $(call BuildTarget))