add ar7 sErCoMm image fix (patch by Bernardo Innocenti)
[openwrt.git] / target / linux / brcm63xx-2.6 / Makefile
index d7b71c803efb1bd24d4e2d2a8011bebf1212111a..b9fd03c9e7fcf10912c5f1d1463ff711772be0a1 100644 (file)
@@ -9,17 +9,13 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
-FEATURES:=squashfs jffs2 broken
+FEATURES:=squashfs jffs2 broken usb atm
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        (e.g. Inventel Livebox, Siemens SE515)
 endef
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
 define Profile/Broadcom
@@ -34,4 +30,10 @@ define Profile/Atheros
 endef
 $(eval $(call Profile,Atheros))
 
+define Profile/Ralink
+  NAME:=Ralink WiFi
+  PACKAGES:=kmod-rt61
+endef
+$(eval $(call Profile,Ralink))
+
 $(eval $(call BuildKernel))