lantiq: add support for tplink images to .../image/Makefile
[openwrt.git] / target / linux / brcm63xx / patches-3.9 / 553-boards_probe_switch.patch
index 56d1dda8d49824ccdc7abefd3b4735309e05a8e2..0d28160279be32f837718514d333b0713c34c4b6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -591,6 +591,8 @@ static struct board_info __initdata boar
+@@ -624,6 +624,8 @@ static struct board_info __initdata boar
        .has_uart0                      = 1,
        .has_enet0                      = 1,
        .enet0 = {
@@ -9,7 +9,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -634,6 +636,8 @@ static struct board_info __initdata boar
+@@ -667,6 +669,8 @@ static struct board_info __initdata boar
        .has_uart0                      = 1,
        .has_enet0                      = 1,
        .enet0 = {
@@ -18,7 +18,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -919,6 +923,8 @@ static struct board_info __initdata boar
+@@ -952,6 +956,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -27,7 +27,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -991,6 +997,8 @@ static struct board_info __initdata boar
+@@ -1024,6 +1030,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -36,7 +36,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1220,6 +1228,8 @@ static struct board_info __initdata boar
+@@ -1253,6 +1261,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -45,7 +45,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1395,6 +1405,8 @@ static struct board_info __initdata boar
+@@ -1428,6 +1438,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -54,7 +54,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1469,6 +1481,8 @@ static struct board_info __initdata boar
+@@ -1502,6 +1514,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -63,7 +63,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1490,6 +1504,8 @@ static struct board_info __initdata boar
+@@ -1523,6 +1537,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -72,7 +72,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1509,6 +1525,8 @@ static struct board_info __initdata boar
+@@ -1542,6 +1558,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -81,7 +81,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1884,6 +1902,8 @@ static struct board_info __initdata boar
+@@ -1917,6 +1935,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -90,7 +90,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1936,6 +1956,8 @@ static struct board_info __initdata boar
+@@ -1969,6 +1989,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -99,7 +99,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2076,6 +2098,8 @@ static struct board_info __initdata boar
+@@ -2109,6 +2131,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2193,6 +2217,8 @@ static struct board_info __initdata boar
+@@ -2226,6 +2250,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {